Web Design With Actinic

Actinic Introduction

Web Design With Actinic

Using Actinic v8

Designing in Dreamweaver

Aim of Session: Create a Design from Scratch in Dreamweaver

Objectives:

· To implement a totally custom design as an Actinic store design.
The Dreamweaver Interface

Actinic comes with an integration into Dreamweaver. This allows you to take a page design that has been created in any web editor, and then use Dreamweaver to turn that page design into an overall page layout.

The integration is installed as a 'Macromedia Extension'. To install it, browse to 'Actinic v8\Extensions\Dreamweaver\Actinic_Assistant' and then double-click on the file called 'Actinic Assistant.mxp'.
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This creates an 'Actinic' menu in Dreamweaver, which is used to drive the interface.
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In this exercise, you are going to take a custom design and turn it into an Actinic overall page layout.

1. Make sure Actinic is open.

2. On your desktop is a folder called 'New Design'. Open it.
3. Right-click on the file called 'new_design.htm' and select 'Edit with Dreamweaver'.
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4. Once it has opened in Dreamweaver, go to the 'Actinic' menu and select 'Register a Design with Actinic'.
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5. Select <All page types> and select 'Register'.
Note: This means that the overall page layout will be used on every page.
6. Now switch back to Actinic.
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The new design has now appeared in Actinic, but there is no Actinic content in it yet.
7. Go back to Dreamweaver. 
8. Click on the 'right column' text. 
9. Go to the 'Actinic' menu and select 'Insert Actinic Content'.
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10. Highlight 'INNERLAYOUT' and select 'Insert and Close'.
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11. Save the changes in Dreamweaver and change back to Actinic.

You'll see that the main content of the page has been inserted into the design.
You can now insert the rest of the design elements.
12. Go back to Dreamweaver.
13. Click on the 'quick search' text in the light-grey box at the right of the top bar.
14. Go to 'Actinic | Insert Actinic Content'.
15. Select 'QuickSearchBar' and click 'Insert and Close'.
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16. Next, click on the 'navigation bar' text.
17. Go to 'Actinic | Insert Actinic Content'.
18. Select 'NavigationBar'.
19. Select the 'Specify Fixed Layout' box.
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20. Select 'Horizontal Nav Bar Text Links' and click 'Insert and Close'.
Note: Doing this means that rather than accepting the default style of navigation bar that Actinic gives you, you can fix a particular navigation bar into the design.
21. Finally, click on the 'left column' text and go to 'Actinic | Insert Actinic Content'. 
22. Select 'TopLevelSectionList' and then select 'Specify Fixed Layout'.
23. Select 'Top Level Section List With Horizontal Dividers' and then click 'Insert and Close'.
[image: image10.png]Orhilin= Sesar=

{QuickSeerchBar]

INavigationBar Horizortel Nav Ber Text Links]

{TopLeveiSectionListTop NNERLAYOUT]
Level Section List With

Forizontal Dividers]





24. Save your changes in Dreamweaver and then go back to Actinic.
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25. Your design has been fully implemented. Test the changes with a full site preview - [image: image12.bmp]
Going from Actinic to Dreamweaver

As well as making changes in Dreamweaver that appear in Actinic, it is also possible to make changes in Actinic and have them appear in Dreamweaver. In this exercise, you are going to insert a variable into the design, which will meant that the HTML titles of your pages will be controlled by Actinic.
Note: This is a little early taster of making design changes in Actinic. You'll be doing a lot of this sort of thing as you go through the day.
1. Go to the Design tab (if you are not there already).
2. In the preview at the top, click anywhere in the top bar of the design. It should highlight the layout code of your page in the panel at the bottom.
3. Locate the <title>New Design</title> line in line 6.
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4. Highlight the 'New Design' text and click the 'Insert Variable' button - [image: image14.bmp]
5. In the 'List names containing' field, type 'pagetitle'.
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6. Select 'PageTitle' from the list and click 'Insert'.
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7. Click 'Apply'.
Note: This change means that the titles of your pages are now controlled by Actinic. 
8. Now go back to Dreamweaver, and you should see this screen.
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9. Click 'Yes' to load the edited page into Dreamweaver.

Actinic Introduction

Aim of Session: To See the Different Places Where Design Can Be Changed In Actinic 

Objectives:

· To change the layouts in your store using layout settings
· To gain a basic familiarity with the 'Design' tab
· To edit other pages in Actinic
· To learn how CSS works in Actinic
Themes and Colours

Actinic has several built-in themes and colour schemes for you to select from.

[image: image18.png]Theme.

Mechanical
Medieval oS00
Modem

Music

Retail

Retio

Slinline

Smart

Sport

Stiipe

echnical
TwenlyFour?

Uses advanced setings

Color

Aquatic
Blue Sky
B-Movie
Carabas

Cool Red

Daiquiri

Coporate Logo

heme_corporate_logo gt | [Conee. ]

‘Advanced Themes Corfigualion, oK Apply Concel





These can often provide a useful place to start when building a design within Actinic. 

As well as selecting one of the basic themes and colour schemes. It is also possible to tweak the different elements of the theme and colour scheme by clicking the 'Advanced Themes Configuration…' button. 

Changing Layouts
Actinic comes with a lot of ways to vary the design.

This section will show you how to use 'Settings | Site Options' to change the appearance of the elements in your store.

First you are going to change how your products look in the store:

1. Go to 'Settings | Site Options' (or click the [image: image19.bmp] button on the toolbar) and change to the 'Layout' tab.
2. Under the 'Product' sub heading, locate the 'Product Layout' field.
Note: This is where you set the default product layout for the whole store. 

3. Change 'Product Layout' to 'Standard With Image On Left'.
4. Change 'Price Layout' to 'Standard Tax Inclusive Price'.
5. Change 'Column Count For Products' to '2'.
6. Change 'Width of Product List' to '580'.
7. Click 'OK' to see the effect these changes have had on the store.
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Next, you are going to put your section links into two columns:
8. Now go back to 'Settings | Site Options | Layout' and under the 'Section' sub-heading, change the 'Column Count For First Row Of Section Lists' and 'Column Count For Section Lists' values both to '2'.

9. Click 'OK' and click on the 'Online Catalogue' icon in the tree to see the effect.
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Overriding Settings

Most of the settings within 'Settings | Site Options' can then be overridden at the section or product level by the user.

This exercise will change how your products look in the 'Computers' section.

Note: Later on you will see how to limit the layout choices available to the user.
1. Change to the 'Content' tab.

2. Click on the 'Computers' section in the content tree.

Note: There is a problem with the layout here – the product list is far too far down on the page. This is because the computer products are too wide (because of their drop down lists) to fit into two columns comfortably.
3. Change to the 'Layout' tab within the section details.
4. Under the 'Product' sub-heading, locate the 'Column Count For Products' field and change the value from 'Use Parent (=2)' to '1'. 
5. Click 'Apply' changes.

The products within the 'Computers' section are now back in one column. 

Overall Layouts

It is possible to use different 'Overall Page Layouts' in different sections in the store. This means that different sections can have different navigational and branding elements across the top of each page, and down the side of each page.

In this exercise you are going to use Dreamweaver to register a second external design (that has been set up and configured already) and then only use this new design for one section in the store.

1. Go back to Dreamweaver

2. Go to 'File | Open' and open the file within your 'New Design' folder called 'alternative_design.htm'.

This is almost identical to your current external design, but it has a blue background rather than a grey one.

Note: This design has been set up already with the Actinic content.

3. Go to 'Actinic | Register A Design With Actinic'.

4. Under 'Use This Design For' select 'Section'.

5. For the 'Name of the new design' enter 'Alternative Design'.
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6. Click 'Register'.

7. Now go back to Actinic.

By default, every section in your store is using the new design. This is because 'Alternative Design' has been set as the default layout for the sections in your store. 

To change this:

8. Go to 'Settings | Site Options | Layout'.

9. Change the 'Overall Page Layout' field back to 'ExternalDesign'.

[image: image23.png]Overall page Layout
PSP Bounce Page Layout
Quick Search Bar Layaut
Recept Page Layout
Top Level Secton List Layout
View Cart Page Layout
= Section
Battom Parent Section List Layout
Bottom Sub Section List Layout

ExternalDesign

[Works Eest with Hyper
orks Eest with Retal
[orks Eest ith Simine.
[Warks Best vith Stripe
[Warks Best vith Smart
[Warks Best with Techrical

st e

[Akernative Desian
<tiew>

3@





10. Click 'OK'.

11. Now go to the 'Stationery' section. 

12. In the 'Layout' tab  change the 'Overall Page Layout' to 'Alternative Design'.
This new design is now being used just for one section.
Point-And-Click Text Formatting

If you look at the top of the Details panel you will see there is a toolbar for text formatting.
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You can highlight text in the descriptions of your products and sections, and use the formatting controls here to change the appearance of it.

Furthermore, by going to the 'Design' tab, you can change the appearance of 'variables' in the design e.g. change the appearance of ALL the product names in the store in one go.

1. Go to the 'Professional Computer Bundle' product in the content tree and change to the 'General' tab.
2. Highlight the word 'Everything' in the full description field.
3. Click on the bold button [image: image25.bmp] in the toolbar to make the word bold.
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4. Click 'Apply changes'.
Note: This has 'embedded' the necessary HTML into the full description to format the text.

This change has just changed part of the description for the product, but it also possible to edit the building blocks of the site to change the appearance of all the products in one go. 

In this exercise, you are going to change all the product names to the same colour as the dark green used in the design.

1. Change to the 'Books' section.

2. Change to the 'Design' tab.
3. Click on a product name in the preview. It will be highlighted with a dotted line.
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4. Use the colour button - [image: image28.bmp] - to change the product name to a dark blue (second colour from the right on the second row).
Note: This has changed the colour of all the product names in your store, not just the one you clicked on.
5. Click on the 'Buy any three example products…' discount message in the preview.
6. Click the italics button - [image: image29.bmp] - to italicize the text.
Almost all the text within Actinic can be edited in the same way.

The Design Tab

The previous exercise showed you a little taste of how you can customise your store pages using the Design tab.
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The most important feature of the Design tab is the Interactive Preview. You can click on any element in the preview to edit it.

Anything you select in the preview screen will appear in the Layout Code panel. You can then make changes here to see the effect it has on the preview.
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You can change section/product by clicking on the Content Tree to the right.

You can view the details of anything selected in the content tree by clicking on the Details tab to view the Details panel.

Finally, it is also possible to view the Design Tree by clicking the tab at the bottom right. This shows you the structure of the current page – and will be covered in more depth later.

Design Overview

Within v8, every aspect of the design and functionality is controlled by just five different objects. Once you learn how these five objects work, you will able to customise the whole of Actinic without too much difficulty.

These five objects are:

· Layouts – every piece of the Actinic design has its appearance controlled a 'Layout'. Layouts contain html code, and are editable via the 'Design' tab.

· Variables – variables sit within layouts, and they are substituted for data within the Actinic database.

· Conditions – these are rules that control when a piece of design is shown or not. Conditions are inserted into layouts via green 'block' tags.

· Layout Selectors – you need some way to be able to select a layout (e.g. choose a product layout) and then have the selected layout inserted into the design. Layout selectors allow this to happen.

· Lists – these control the insertion of multiple items into the page. They insert code at the top and bottom of the list of items, and control how many columns are in the list, whether there is a line between each row in the list etc.

This is the architecture of design in Actinic. Everything you see springs from these five basic concepts.

Layout Code

Within the layout code you will see the following:
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(in blue)
	A variable. Will be substituted for some data in the database. 
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(in purple)
	A layout selector. Shows where a layout is being inserted within the current layout. Right-click and select 'Navigate To' to view the inserted layout.
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	A conditional block. Double-click on the opening block tag to view the condition


Coding Errors

'Design | Check Coding Errors' will scan through all your pages and tell you whether there are any problems with them.
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Double-click on an error to be taken to where the error is in the design.

If the [image: image36.png]


 is illuminated, it means there are problems on the page. Click the button to see the errors.

Making Changes

The appearance of everything in an Actinic design is controlled by a 'Layout' e.g. the quick search is a layout, the add to cart button is a layout, the postcode field in the checkout is a layout etc. etc.

When you click on any item in the interactive preview, the HTML code for the layout that lays out that item appears within the 'Layout Code' panel at the bottom. In the title bar you will see the name of the layout.

[image: image37.png]Books

Cotring
Homeware
computers
Statonery

Best Seers

New Products

<

5
10

WO RS

Procct Detats - Great e

; Layout Code - Standard With Image On Left

Edit Layout Details

-
i
ey | A2 AT £
Pice £33 Jane Austen
J—

exampie products, N
and you'll receive X
e cresposone

foe o Hre

seo the available

CHARLES

DICKENS Pride and Prejudice

Pride and
Prejudice

Jane Austerts =
classiotale of
intigue, suspense
and romance.
Price: £4.00

Buyany three
example products,

andyou receive

the cheapest ane

free. Click HEREto £

<imput type="hidden” name='"SHOP" value="HiddenFields" />

/plock

11 L/plock

12

13 <table widch="100%" cellspacing="0" cellpadding="10" border="0">
18 <tr>

15 <td wideh="255" align="center” valign="top">
16 ProductImageLayout

17 </ta>

18 <td wideh="755" align="left” valign="top">
19 <a name="EncodedProduotinchor">

20 <b>Productiames/h></a>

21

apply  Concel oK

B
i Ele Edt Settings Design Operations Marketing Web Housekeeping Window Help
24 R TSRS 2T N2 | A
EForders |
; Page Preview 2 X} Content Tree 2 x
£ Select Page Type Content Page H 2 Home

@ [ vore Pages
5 @ Onine Catalogue
5 Books

@ Pride and Prejudce
© FerFrom The Madding Crone
& [ cithia
Homenare
@ Tespot
@ Setof Glasses
& B Computers
# @ Stater Computer Eundle
5 @ Proessional Computer Eund)
17 ch Monitor
19 nch Venitor
21 inch Maritor

©
5 staionery
et sllrs

New Procicts
& ) pair of Casua Shoes

m | 3

tatons

@ besin Tree

For Help, press F1

[





This is a basic exercise to get you used to using layouts.

1. In the interactive preview, click on the 'Contact Us' text (in the navigation bar). It should highlight a variable called 'SendMailText' within a layout called 'Contact Us Text Link'.
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2. Just after the 'SendMailText' variable, add '…' and click 'Apply'.
3. You should see the '…' appearing in the preview. 
4. Now replace the '…' with '>>' and click 'Apply'.
[image: image39.png]



5. Now press the 'Undo' button on the toolbar - [image: image40.bmp]
This should take you back to having '…'
6. Now press the 'Redo' button on the toolbar - [image: image41.bmp]
This should restore the '>>'.
7. Next, click on a section name in the list down the left hand side of the site.
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8. This should highlight a variable called 'SectionName' in a layout called 'Section Name Only Section Link'
9. Again, add '>>' after the 'SectionName' variable and click 'Apply'.
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Note: This has changed every section link, not just the one you clicked on. This is because the section links are being laid out as a 'List', with the same layout being used multiple times. Lists are described in more detail later.

Editing Other Pages

As well as selecting pages in the content tree to edit, it is possible to edit other pages such as the 'View Cart' page, the 'Search' page or the 'Checkout'.

In the Design tab there is a 'Select Page Type' drop down list at the top left of the preview. This contains a list of all the other pages that can be edited via the Design tab.
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1. Select 'Shopping Cart' in the 'Select Page Type' list.
2. Click on the 'Shopping Cart' caption at the top of the page.
[image: image45.png]et




3. It should highlight some blue text that says 'CartCaption' in the layout.
4. Delete 'CartCaption' and replace it with the text 'Your Order Details'.
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5. Click 'Apply'.
This has changed the text that will appear above the shopping cart table on the 'View Cart' page.

Next, you are going to make some changes to the receipt page.

1. Select 'Receipt' from the 'Select Page Type' drop down list.
[image: image47.png]Computers
Stationery

Best Selers

New Products

(Tf there are errors gemerated during the shopping process they will be placed
here)

{Print his page and keep & for your records. I you nesd o contact us, rfer 1o the "Orcer Number”
has been recorded. Pease fil n your crect card detals below:. Then take his page and fax, phone, o mal 10} My
Name} (MyNiame@mycompany.com}

elow. Your arder

(cick hereto dowrioad) 9
@





There is a problem with this design, as the receipt page content doesn't fit neatly into the page, and so it is shunted down below the top level section list. To fix this:
2. Go to 'Settings | Site Options | Layout'.
3. In the 'Site' area at the top, find the 'Receipt Page Layout' field.
4. Change this field from 'ExternalDesign' to 'Receipt Page Layout'.
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5. Finally, click on the '[Your Receipt]' text at the left-hand side of the top bar.
6. Use the colour button - [image: image49.bmp] - to change the colour of this to white.
You can do the same thing to some of the other headings in the page if you have time.
Editing CSS

Many of the elements in the Actinic store get their formatting from the 'Actinic Stylesheet'.

Note: The 'Actinic Stylesheet' layout becomes a file on the website called 'actinic.css'.

You can view the stylesheet by going to the 'Select Page Type' drop down list in the Design tab, or within the 'Web Page Outer Layout' group in the 'Layouts' tab of 'Design | Library'.
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Note: You'll be looking at the library later on in the course.

Some of themes use CSS extensively for almost all layout and positioning. These themes are:

· Executive
· Clean CSS Layout
· Contemporary
· Technical
The rest of the themes really only use CSS for text formatting, and rely on HTML tables for their layout.

There are two other places where styles might be defined for a site:

· Within the <head> tag of the page's outer layout.
· Within a file called 'theme.css' in the site directory (e.g. 'Site1')
It is worth checking these two locations if you cannot find style information in the 'Actinic Stylesheet' layout.

In this exercise, you will format how product names look within a product layout.

1. Go the 'Computers' section in the content tree and change to the 'Layout' tab.
2. Change the 'Product Layout' from 'Use Parent' to 'Standard Layout Using CSS'.
3. Click 'Apply changes'.

This has changed the product layout used in the 'Computers' section.
4. Now change to the Design tab (if you are not there already). 
5. Click on the product names of one of the computers on this page.
In the layout code you should see the following line:

[image: image52.png]"product ">ProductHamel /h3>




The product names are getting their formatting from the <h3> tag, and this is being customised by a class called 'product' in the CSS file. You are going to edit this class.

1. Go to 'Design | Library' and switch to the 'Layouts' tab.
2. Go to the bottom of the library and find the 'Web Page Outer Layout' group. Click the '+' to expand this group.

3. Locate 'Actinic Stylesheet' and double-click on it.
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4. Right-click within the layout code and select 'Find'.
5. Click within the 'Search for text' field and enter 'h3.product'. 
6. Click 'Find Next in Code'.
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7. Change the 'padding' command from:
padding: 0px 0px 6px 0px;
to
padding: 3px;
8. Change the 'color' line from:
color: Palette2;
to
background-color: Palette2;
9. Just above the new 'background-color' line, add a new blank row and add:
color: white;
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10. Click 'OK' and then close the library.

To see the effect this change has had, you need to carry out a full site preview - [image: image56.bmp].
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Note: When working with the Actinic Stylesheet layout, the 'Find' feature is invaluable for locating the style you want to edit.
Variables

Aim of Session: To Learn How to Utilise, Edit and Create Variables
Objectives:

· To add a new variable into the design
· To look up a variable in the 'Variable Reference Guide'

· To create new variables and add them into the design
· To limit variables by content category

Adding Variables into the Design

When you clicked on the product names earlier to change the colour of them, you were actually editing a 'variable' in the design called 'ProductName'. A variable is a placeholder for a piece of Actinic data. In the layout code they appear in blue.

[image: image58.png]ProductHame




When Actinic generates the pages, it substitutes these variables for data within the Actinic application.

You can use the 'Insert Variable' toolbar button at the top of the layout code panel to add new variables into the design.
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In this exercise you will add a variable into the design – in this case it is the company name, which will be inserted at the top of each section page.

1. In the preview in the Design tab, click the section name at the top of the page.
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2. This should highlight a variable called 'SectionName' at the top of the section.
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3. Put your cursor just before the 'SectionName' variable and click the 'Insert Variable' button - [image: image62.bmp]
4. In the 'List Names Containing' box, type 'CompanyN'.
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5. Locate 'CompanyName' in the list and click 'Insert'.
6. Click 'Apply'.
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7. Now put your cursor in between the 'CompanyName' and 'SectionName' variables and add a ' – ' to separate them.
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8. Finally, go to 'Business Settings | Company/Contact' and change the 'Name' field to something other than 'My Company'.

9. Click 'OK' to see the effect.

Variable Reference Guide

If you are not sure about what a variable does, you can look it up in the 'Variable Reference Guide'. 

1. Go to 'Help | Variable Reference Guide'.
2. Change to the 'Search' tab.
3. Type 'companyname' and click 'List Topics'.
4. Double-click on the 'CompanyName' topic.
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This shows you a brief description, and also shows you where the value of the variable can be set.

Creating Variables
It is possible to add your own custom variables to Actinic. They are called 'User-Definable Variables' and appear in grids like this:
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You can customise whether the values for the variables can be set at the section or product level (or even fragment level, component level, choice level etc.) and can also control what tab they appear in. You can also preset a list of choices for the values, and select a default value.
In this exercise, you are going to create an 'ISBN' and an 'Author' variable for your books. You will see that there is a variety of ways to create variables.
Method 1

1. Go to 'Design | Library' and change to the 'Variables' tab. 
Note: You'll see what the 'Layouts' tab is for later.
The Variables tab contains all the custom variables that come with Actinic. They are sorted by product area. 
2. Right click on the 'Product' entry in the tree and select 'New Variable'.
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3. In the 'Name' field enter 'ISBN'.
4. In the 'Description' field enter 'The ISBN number for the books in the store'.
5. In the 'Prompt' field enter 'ISBN'.
6. Under 'Place of Setting', select 'Product'.
7. De-select 'Allow <Use Parent> as an Option'
Note: This means the value won't 'inherit' down the store structure.
8. Leave the 'Tab Name' as 'Properties'.
9. Click 'OK'. 
Your new user-definable variable will appear in the library.
To see the setting for this variable you need to close the library and go to the 'Properties' tab of your products. You'll see the ISBN setting in the grid.
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Method 2

This will create a new variable while you are editing the design.

1. Change to the Design tab (if you are not there already).
2. Make sure you are in the 'Books' section.
3. In the preview, click on one of the product names. It should highlight the 'ProductName' variable in the layout code.
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4. There should be a blank line underneath this line. In the blank line add a <br /> 
Note: You might notice that the software prompts you to help you enter the correct HTML tag in.
5. Then press the 'Insert Variable' button on the toolbar - [image: image71.png]Q@
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6. Press 'New' and you will be in the 'Edit Variable' window again.
7. In the 'Name' field enter 'Author'.
8. In the 'Description' field enter 'The author of the books'.
9. In the 'Prompt' field enter 'Enter Author Name'.
10. Set the 'Group' field to 'Product'.
11. Under 'Place of Setting', select 'Product'.
12. De-select 'Allow <Use Parent> as an Option'
13. Leave the 'Tab Name' as 'Properties'.
14. Change 'Type' to 'List of Choices' and press the 'Choices' button. 
This takes you to the 'Values' tab.
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15. Press 'New' and type 'Select Author'
16. Press 'New' again and type 'Charles Dickens'.
17. Press 'New' again and type 'Jane Austen'.
18. Press 'New' again and type 'Thomas Hardy'.
19. Change back to the 'Basic Definition' tab.
20. Select 'Allow <New> as an Option'.
Note: This means if you add any new books, you can add new author names to this list.
21. Make sure both 'Initial Value' and 'Top Level Value' are set to 'Select Author'.
22. Click 'OK'.
You will be shown the list of variables again, but this time 'Author' should be in the list.
23. Select 'Author' and click 'Insert'.
24. Click 'Apply'.
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You are now going to add the 'ISBN' number into the design.
25. Now put your cursor after 'Author' and press 'Enter' on your keyboard to add in a new line.
26. Put in another <br /> and then start typing 'ISBN'
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27. Select 'ISBN' from the list that appears and press 'Enter' on your keyboard.
28. Now add in another <br /> and press 'Apply'.
[image: image76.png]<b>Productiame</h></a>
<br />huchor
<br />ISH<hr />
block if
Re:

ProductReference





You are now ready to add some data in for these variables.
1. Change to the 'Content' tab.
2. Click on 'Great Expectations' and go to the 'Properties' tab.
3. Select an 'Author' of 'Charles Dickens' and enter an ISBN number of '12345'.
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4. Now fill in values for 'Author' and 'ISBN' for the other two books in the section.
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Note: Don't worry about the 'Select Author' text that appears for the other products (and the big gap). In a later exercise you will remove these.
Content Categories
The two new variables - 'Author' and 'ISBN' – work brilliantly for the books, but they also appear within the 'Properties' tabs of all your products in the store.

It is possible, however to limit the fields to only appearing for the book products by creating a new 'Content Category' called 'Books' and limiting the two new variables to only appear for that content category.

1. Go to 'Design | Content Categories'.
2. Highlight 'Product'.
3. Click 'New'.
4. Enter a name of 'Books'.
5. Click 'OK'.
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You now need to categorise your three book products as being 'Books'.
6. Go to the 'Great Expectations' product and go to the 'General' tab.
7. Change the 'Category' field to 'Books'.
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8. Now repeat the process for 'Pride and Prejudice' and 'Far From The Madding Crowd'.
Now you have done this, you are ready to limit the two new fields by 'Content Category'.
9. Go to 'Design | Library' and switch to the 'Variables' tab.
10. Locate the 'ISBN' variable within the 'Products' group and double-click on it.
11. Change to the 'Advanced Place Of Setting' tab.
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12. Expand 'Product' in the tree and de-select 'Standard'.
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13. Click 'OK'.
14. Click 'OK on the warning message that appears.
15. Now double-click on 'Author' and repeat the process.
Note: Because 'Author' has a range of choices available, it is possible limit the different choices to different content categories.

16. Finally, go to a product that is not a book. You should find that the 'Author' and 'ISBN' settings have gone.

The Appearance Window

The 'Appearance' window can be used to finely configure the appearance of variables in the design.

1. Go to the 'Clothing' section.
2. Change the Design tab (if you are not there already).
3. Click on the 'Basic T' product name in order to highlight the 'ProductName' variable in the layout code.
4. Right-click on the 'ProductName' variable and select 'Edit Appearance'.
[image: image83.png]Edit Appearance

=igite
Bold fabe
casstyle
Encading Leave AsIs
Font Color 39966
Font Name
Font Size
Italc
style
Underlne
= Other
Condian
Selectable





In the 'Font Color' row, you will see the code for the blue font colour you selected earlier.

'Edit Appearance' is used for a couple of other things, as you will see later. 

Note: You can click on any settings here to change the appearance of the variable.

Formatting In The Layout Code

When you look at the layout code normally, you are looking at a 'basic' view, where variables, layout selectors etc. are compacted in an 'easy-to-view' style.

Click the 'Toggle Basic/Advanced' button on the layout code toolbar to view the full underlying code.
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It's in this 'Advanced' view where you can see the formatting applied by the 'point-and-click' text formatting.
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Layouts

Aim of Session: To Master the Concept of Layouts

Objectives:

· To edit layouts via the Design tab, and then undo changes
· To understand the Design Tree
· To create new layouts

· To import layouts
· To edit the layout selectors that control how layouts are selected
· To add new layouts into the design

· To edit content lists
Creating New Layouts

It is possible to create your own custom layouts in Actinic and have them included in the list of layouts offered by the software.

In this exercise you will create a 'Sale' layout for your products.
1. Go to the 'Teapot' product in the content tree and view the details.
Note: This could be any product – not necessarily the teapot.
2. Change to the 'Layout' tab.
3. In the 'Product Layout' field, select <New> (from the bottom of the list).
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4. In the 'Layout Name' field, enter 'Sale Layout'.
5. In the 'Based On' field, select 'Standard With Image On Left'.
6. Click 'OK'.
7. Click 'Apply changes'.
The 'Teapot' is now using the new 'Sale Layout', but it still looks the same.
8. In the interactive preview, click on the 'Teapot' product name and look at the Layout Code panel.
9. Use the colour button - [image: image87.bmp] - to change the colour of the product name to red.
Note: When you did this earlier it changed the colour of all the product names. Now however, it has only changed one product. This is because only one product in this section (the teapot) is using the 'Sale Layout'.
10. Now place your cursor after the 'ProductName' variable in the 'Sale Layout'.
11. Type: <span style="color:red;"> - ON SALE</span>
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Note: The colour button only works on variables – not on text.
You can now use this 'Sale Layout' layout whenever you want a product to appear on sale.

The Library

Your new layout has now been added to the 'Library'. The library is where all the layouts used by Actinic are kept.
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To access all the layouts in the library, go to 'Design | Library' and switch to the 'Layouts' tab. 

To view your new 'Sale Layout', go to the 'Products' group. You can then double-click on any layout to edit it.
Note: You can also create new layouts via the library. Simply right-click on one and select 'New Layout'.
If you have made a change to one of the layouts that came with Actinic, and you want to put the layout back to how it was originally, you can right-click on a layout in the library and select 'Revert to Factory Settings'.
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The Design Tree
Click the 'Design Tree' tab at the bottom right of the Design tab.

This is the Design Tree – which shows you visually all the layouts used in the current page shown in the preview. You can click on the layouts shown in the tree  - [image: image91.bmp] - to select them in the preview.

Layout Selectors
When you choose a layout in Actinic (e.g. Product Layout) what you are doing is selecting from a range of layouts offered by a 'Layout Selector'. 
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They work in a very similar way to the 'Author' variable you created earlier – in that they offer a range of choices to select from, and then the selected choice is then inserted into the design. 

You can add layout selectors into your design and they will be substituted for a layout – not just a piece of text.
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You can view and edit layout selectors from the 'Layouts' tab in the library. 
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In this exercise you are going to move your 'Sale Layout' layout so it is first in the list.

1. Go to 'Design | Library' and switch to the 'Layouts' tab.
2. Go to the 'Products' group and double click on the 'ProductLayout' layout selector.
3. Change to the 'Values' tab.
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4. Click on the 'Sale Layout' and use the arrows to move it to the top of the list.
Note: If you wanted to stop any layouts being offered in Actinic, you can use the '<' button to remove them from the list.
5. Click 'OK' and close the library.
Now when you go to the 'Product Layout' setting for a product, 'Sale Layout' should be first in the list.
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Limiting Layouts by Content Category

It is possible to filter the list of layouts by content category – so different content categories see different layouts.
In this exercise you are going to prevent the 'Sale Layout' from being an option for your book products.

1. Open the 'ProductLayout' layout selector (if you are not there already).
2. Change to the 'Advanced Place Of Setting' tab.
3. Expand 'Product' in the tree.
4. Expand 'Books'.
5. De-select the 'Sale Layout' option.
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6. Click 'OK' and then close the library.
7. Now change to the 'Books' section and go to the 'Layout' tab of one of your books.
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The 'Sale Layout' is no longer offered as an option.

Importing Layouts

It is possible to select just a few specific design elements to export as a 'snapshot'. You can then send the snapshot to a customer, for them to import into their copies of Actinic.
Note: You can do this even if the customer is using a 'Client' copy of Actinic.

This allows you to update the layouts that are available for your customers to select from, and even update your customers' installations with new user-definable variables and content categories.

In this exercise you will import some new layouts that have already been exported. Later on you will see how to create your own design snapshots.

1. Go to 'File | Snapshot | Import Site'.
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2. Click 'Next' and then 'Next' again.
3. On the next screen, select 'Browse' and double-click on the file called 'banner_adverts.acd' on your desktop. Click 'Next' to continue.
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Note: This screen contains a description of what the snapshot contains.
4. Keeping clicking 'Next' until the import starts.
5. Click 'Finish' once the import is completed.
The new layouts are now in the library.
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In the next exercise you are going to create a layout selector to insert these layouts into the design.

Creating New Layout Selectors

In the last exercise, you imported two new layouts. Next, you need to create a new layout selector so that these layouts can be inserted into the design.

1. Go to 'Design | Library | Layouts' (if you are not there already) and locate the 'Banner Adverts' group in the library.
2. Right-click on the 'Banner Adverts' group name and select 'New Selector'.
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3. Give the selector a name of 'BannerAdvert'.
4. For the description, type 'Inserts a banner advert into the top of each page'.
5. For the prompt, type 'Banner Advert'.
6. For 'Group' you can leave it as 'Other'.
7. Under 'Place of Setting' select 'Site' and 'Section'.
8. Select 'Allow <No Layout> as an Option'.
9. Change 'Tab Name' to 'Layout'.
10. Now change to the 'Values' tab.
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11. Press the '>' button twice to move both layouts into the 'Layouts Offered By This Selector' list.
12. Change back to the 'Basic Definition' tab.
13. Change the 'Top Level Value' to 'Red Banner Advert'.
14. Click 'OK'.

You can now go the 'Layout' tab of 'Site Options', or your sections. The new 'Banner Advert' field should be under a sub-heading of 'Other'.
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Adding Layouts into the Design
Just as you can add variables into your layouts, you can also add layout selectors into your layouts.

In this exercise, you are going to insert the banner adverts into the top of each section page.

1. In the 'Design' tab, look at any section page and click on the section name that is at the top of the section.
2. In the layout code, put your cursor in the blank line just below the 'Message for Unregistered Customers' layout selector. This should be line 29.
3. Click the 'Insert Layout' button - [image: image105.bmp].
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4. From the list of layout selectors, select 'BannerAdvert' and click 'Insert'.
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5. Click 'Apply'.
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6. Now go to the 'Layout' tab of any section in the store. 
7. Scroll down to the bottom so you see the 'Banner Advert' field.
8. Change the value to 'Blue Banner Advert' and click 'Apply changes' to see the effect.
9. Now change the value to 'No Layout' and click 'Apply changes' to see the effect.
Fixing Layouts

The default layouts are packed full of layout selectors. Some of them look like this: 

[image: image109.png]ProductLayout




When you just see the name of the layout selector, it means the layout to be inserted is controlled from somewhere in the software. It could be set in 'Site Options', or in the 'Layout' tab of a product, or even in the 'Basic Definition' tab of the variable itself.

Some layout selectors, however, look like this:
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This is a layout selector where the layout to be inserted has been 'fixed' in the design. This cannot be varied by editing settings elsewhere in the software.

In this exercise you will add a new 'Brochure Navigation Bar' to the sidebar, and 'fix' the layout to use.
1. Click on the 'Product Sections' text above the section list in the sidebar.
2. You should now be in a layout called 'Top Level Section List With Horizontal Dividers'.
3. Click the [image: image111.bmp] button on the toolbar below the layout code – or click the [image: image112.bmp] icon (up arrow) that is in the row of arrows above the selection box.

Note: This takes you 'up' a level in the structure of layouts that are used in your store.
4. You will hopefully now be in a layout called 'ExternalDesign'. If you are not there, press the up arrow again.
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Note: The layout selector that is highlighted is the one that inserts the layout you were just in.
5. Add a new blank line above the 'Top Level Section List With Horizontal Dividers' layout selector.
6. Click the 'Insert Layout' button - [image: image114.bmp]
7. In the top list, select 'BrochureNavBar'.
You don't just want to insert the 'BrochureNavBar' layout selector as it is, you need to fix the layout so that the brochure navigation bar of the correct style will be inserted.
8. Select the 'Use Fixed Layout' box.
9. In the list at the bottom, select 'Brochure Nav Bar With Horizontal Dividers'.
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10. Click 'Insert'.

11. Click 'Apply'.
The brochure navigation bar should now be in the sidebar.
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Content Lists

Earlier today, you changed the layout of the section links in the sidebar of Actinic. 
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You edited a single layout, but it changed all the section links in the sidebar. This is because there is an item in Actinic called a 'List', which is responsible for inserting the section link layout multiple times into the page – once for each top level section in the store.

In the same way, when you change the layout of one product, it changes all the products on the page. Again, this is because there is a 'Standard Product List' item, which inserts the product layout multiple times into the design.

This exercise will show you how to customise lists – specifically the top-level section list in the sidebar.

1. Click on the 'Product Sections' text above the section list in the sidebar.
2. You should now be looking at a list layout called 'Top Level Section List With Horizontal Dividers'.
Note: You can tell you are editing a list because there is an orange link at the top that says 'Click here to edit list layout settings'.
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3. Click on the 'Click here to edit list layout settings' link.
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4. In the 'Start of List' field, you should be able to see the 'Product Sections' text.
5. Click the 'Edit' button.
6. Change the 'Product Sections' text to read 'Categories'.
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7. Click 'OK'.
8. Click 'OK' again to confirm the change.
This has changed the text that appears above the list of sections.
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It is also possible to edit the code that goes before and after each item in the list.
1. Click the 'Click here to edit list layout settings' link again.
2. Change to the 'Edit Rows and Columns' tab. 
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This shows you the code that goes before and after each item in the list – in this case, it is the code that formats the entries in the list, and inserts a horizontal line in between each one.

3. Click in the 'After' field for the 'First Item' in the 'Middle Rows'. 
4. Click the '…' button to edit the text in this field.
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5. Locate the tag
<div class="dotted_line_blue">
and change it to read
<div class="solid_line_blue">
6. Click 'OK' and then 'OK' again.
7. You should see the line between each section list entry has become darker.
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Note: In the Design Tree and the library, lists have this icon: [image: image125.bmp]
Conditions

Aim Of Session: To Understand How Conditions Change the Way Your Store Functions

Objectives:

· To understand the concept of conditionality
· To hide line breaks and formatting that are not required
· To include an automatic low stock warning message into the design
Conditionality
'Conditions' allow you to show/hide pieces of your design based on settings in Actinic. They allow you to not just change the way Actinic looks, but also change the way Actinic works.

Conditions in Actinic look like this:
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The text between the two 'block' tags will only be shown if the condition statement is 'true'. You can specify the condition statement using variables and rules that control when to display the text.

Note: If you ever want edit a condition statement, double-click on the opening 'block' tag. This shows you the condition that must be 'true' in order for the text to appear.

In this exercise, you will include a stock message into the bottom of your standard product layout that will only appear if the stock level falls below 10.
1. Click on one of your book products in the content tree.
2. Switch to the 'Design' tab (if you are not there already).
3. Make sure you have the product layout selected. It should be called 'Standard With Image On Left'.
4. Scroll down to the bottom of the layout code until you find the 'ProductRelatedProductsList' layout selector.
5. Underneath this, create a new line and type: 
<p>We are starting to run low on this product</p>.
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6. Click 'Apply'.

This message should appear at the bottom of all your products.
7. Now highlight this new line (in the Layout Code panel) and click the 'Insert Block' button - [image: image128.bmp]
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This is the 'Condition Editor' where you create the conditions to control the functionality of the 'block' tags.
8. Type a standard left bracket – '('
9. Click the 'Insert Variable' button - [image: image130.png]Q@



 - and from the list select 'StockLevel'.
Note: You can filter the list by typing 'Stock' in the 'List names containing' field.
10. Highlight 'StockLevel' and click 'Insert' (or just double-click on 'StockLevel').
11. Then from the 'Insert an operator into the expression' list, select 'Less Than'.
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12. Then type '10' followed by a standard right bracket.
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That will work well for all the stock monitored products, but it will not work correctly for any product that is not stock monitored. This is because products that are not stock monitored can have stock levels of '0' but can still be ordered online. Therefore you need to clarify this condition by saying '… and the product must also be stock monitored'.
This is done with a true/false variable called 'IsStockMonitored',
13. From the 'Insert an operator into expression list, select 'And'.
14. Start typing 'IsStockMonitored' into the Condition Editor. It should prompt you to insert 'IsStockMonitored'. Press 'Enter' to insert it.
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15. Click 'OK'.
To test the condition, try taking the stock level of a product below 10 and see whether the message appears.
More Information: The Appearance Window

The Appearance window (right-click on a variable or selector and select 'Edit Appearance') can also be used to apply conditions directly into a variable or layout selector.
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This is an alternative to using block tags when all you want to hide is a single variable or layout selector.

Reusable Conditions
In the library, there is a tab called 'Conditions'.
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This is where 'Reusable Conditions' are stored. They are conditions that are defined once, and then can be called from anywhere else in the store.
You are now going to create a reusable condition to hide the 'Author' and the 'ISBN' code (with the accompanying <br /> tags) when those fields are not filled in.

1. Go to 'Design | Library' and switch to the 'Conditions' tab.
2. Right-click on the 'Product' group and select 'New Condition'.
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3. In the 'Name' field enter 'IsABook'.
4. In the 'Description' field, enter 'Only true if Author and ISBN are filled in'.
5. In the 'Prompt' field, enter 'Is A Book'. 
Note: The Prompt field doesn't really get used anywhere.
6. Go to the 'Condition' field and type a standard left bracket – '('.
7. Insert the 'ISBN' variable into the condition editor.
8. From the 'Insert an operator…' menu, select 'Is Not Empty'.
9. Type a standard right bracket - ')'.
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10. Go to the 'Insert an operator…' list again and select 'And'.
11. Now type a standard left bracket – '(' – and insert the 'Author' variable into the condition editor.
12. From the 'Insert an operator…' list, select 'Not Equal'.
13. Then type:
'Select Author'
including the single quotes.
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14. Click 'OK' and close the library.
You can now add this condition into your two product layouts ('Sale Layout' and 'Standard With Image On Left').
15. Go to the 'Teapot' product and select the 'Sale Layout' product layout.
16. Highlight the two lines that contain 'Author' and 'ISBN'.
[image: image139.png]<td width="755" align="left" v
<a neme="EncodedProductAnch
<b>ProductName<span style

block if
Ref: ProductReference

block





17. Click the 'Insert Block' button - [image: image140.bmp].
18. Now click the 'Insert Condition' button - [image: image141.bmp].
19. From the list select 'IsABook' and press 'Insert'.
Note: You can just start typing 'IsABook' and it will be selected for you in the list.
20. Click 'OK' and then press 'Apply' to confirm the changes to the layout.
This has removed the unwanted content from the 'Teapot' product, but now you need to do it for all the other product layouts.
21. Click on the 'Set of Glasses' product in the interactive preview. This should select the layout called 'Standard With Image On Left'.
22. Repeat the steps above to add the 'IsABook' condition into this layout too.
You should now find that the unwanted 'Select Author' text and line breaks have been removed from your non-book products.

Note: The advantage of the reusable condition here is that if you need to make any changes to the condition, you only have to make the changes once.

PHP
Actinic supports the use of standard PHP expressions in conditions. For example:
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This expression will return 'true' if the first three characters of the product reference match 'cat'. 

Deployment and Implementation

Aim of Session: To Hand Over Your Designs To Your Customers

Objectives:

· To learn how to deploy an entire site
· To learn how to just deploy a design
· To see how to use importing and linking to quickly populate a site with products
Deploying an Entire Site

When you are ready to hand over the site to the customer, go to 'Design | Deploy Site Snapshot'.
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This works in the same way as a standard snapshot, until you get to this screen:
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This is where you can set whether your client is just managing the orders, or is managing the entire site. It is also possible to set how much will be overwritten in the client's installation when they import the snapshot. Finally, you can disable certain features such as Design Changes or Network Setup.

Note: If you are importing this into a Client version of Catalog or Business, design changes will already be disabled.

When you click 'Next', you will see this screen:
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This is where you can set a different splash screen image to appear when the customer starts Actinic, and you can even give the product a different 'Name' to appear in the title bar of the program, and in 'Help | About…'.

Then when you click 'Next' you will complete the snapshot and the whole site will be saved as a file with an extension of *.acd. This can then be imported by your clients by going to 'File | Snapshot | Import Site'. 

[image: image146.png]i[ Fie | Edt Settings Design Operations  Merketing Wb

Stes,

Import

Import Sage Line 50 Data.

Exot
Snepshot. »] | o see
| e Set inport 5t

B = =




Separating Design and Content

As well as sending customers an entire site, with design and content all in one file, it is possible to just send the customer a design – without the content. This is done by going to 'Design | Deploy Partial Site Design'.
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This leads you through a wizard where you can complete the following steps:
· Choose a location to create the file

· Enter a description to appear as customers start the import process

· Choose the layouts to export

· Choose the layout selectors and variables to export

· Choose the conditions to export

· Choose the content categories to export

· Choose the custom tabs to export

· Specify any additional files to export

You can simply select everything to export a complete design. Alternatively, you can just export specific design objects – such as the banner adverts.

1. Go to 'Design | Deploy Partial Site Design' and click 'Next' twice.
2. Click 'Browse' and browse to the desktop. 
3. Enter a filename of 'test.acd' and click 'Save'.
4. Click 'Next'.
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5. For the description, enter 'Two banner adverts and their layout selector'.
6. Click 'Next'.
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7. Click 'Select None' and then select the box next to 'Banner Adverts'.
8. Click 'Next'.
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9. Click 'Select None' and then expand 'Other'. 
10. Select 'BannerAdvert' and click 'Next'.

11. Click 'Select None' and click 'Next'.

12. Click 'Select None' and click 'Next'. 

13. Click 'Select None' and click 'Next'. 
14. Click 'Next' a further 2 times to complete the export.

Importing and Linking

Importing and linking provide a quick way to get lots of information into Actinic quickly. 
Importing

Actinic's import feature allows you to take an existing spreadsheet of products and bring it into Actinic in one operation. 
Actinic's import wizard is started by going to 'File | Import'
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Before you start the import, there is a little bit of work required to prepare the data for import. For this training session, you are going to import two new sections called 'Aquariums' and 'Fish'.

1. Locate the file called 'aquarium_store.xls' on your desktop.

2. Open the file in Microsoft Excel.
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The first thing you are going to do is change the column headings in the import file to be the same as the field names within Actinic. This is so Actinic automatically knows which field to put the information in.

Note: You don't actually have to do this stage as Actinic's import wizard does have a 'mapping' feature where you can map custom column headings onto Actinic's field names.

3. Click within the 'Product Name' field heading.

4. Change it to read 'Short Description'.

5. Save your changes.

Note: All prices have to be imported in the lowest denominator of the currency (i.e. in pence).

Also, if you specify an image filename, you need to tell Actinic where to find the image – either provide a full file path, or make it relative to the 'Site1' folder.

Finally, you need to put sections and subsections into a single field, and separate them with a '|' e.g. 'Aquariums|Accessories'. 

Next, you are going to save the Excel file as a 'CSV' file. This is a universal format that can be read by lots of different applications, such as Actinic.

6. In Excel, go to 'File | Save As'.

7. In the 'Save as type' box, select 'CSV (Comma delimited)' 
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8. Click 'Save'

9. Click 'OK' on the first warning message that appears, and then click 'Yes' on the next one.

10. Close Excel. When Excel prompts you to save, click 'No'. 

You are now ready to import this file into Actinic. Before you do, however, you need to tell Actinic that you want to use your own custom product references, rather than ones automatically provided by Actinic.

To do this:

1. In 'Actinic', go to 'Settings | Business Settings'. 

2. Change to the 'Options' tab.

3. De-select the box labelled 'Auto Generate Product References'
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4. Select 'Hide Product Reference in Online Catalog'

5. Click 'OK'.

You are now ready to start the import.

1. Go to 'File | Import'.

2. On the new window, select 'Flat File Import' and click 'Next'.

3. For the 'File Name' field, click the 'Browse' button and locate 'aquarium_store.csv' on your desktop.
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4. Make sure all the remaining settings look like the screenshot above.

5. Click 'Next'.

This is the 'Mappings' screen where you can use drag and drop to match your custom column headings to the Actinic field names. Fortunately, as they already match the Actinic field headings, there is no need to do anything here.

6. Then click 'Next' again and click 'OK' on the warning message that appears.

7. Click 'Finish' to start the import.

Your new sections should be added into the bottom of the content tree.
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Linking

Actinic Business (and Actinic Designer) allows you to go one step further than a basic import, and allow customers to maintain their product data outside of Actinic (in a program like Excel or Access) and then dynamically update Actinic.
Also, when stock levels change in Actinic (as orders are retrieved) the external data file is updated automatically.

1. Go to 'File | External Links'. 
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2. Select 'Link Products To Table in an External Database'.
3. Select 'Enable Updates to External Data'.
4. Select 'Link all Products to External Data if Available'.
5. Click 'Browse'.
6. Select 'Excel 97 and later workbook' and click 'OK'.
7. For the 'Workbook file' select 'aquarium_store.xls' on the desktop.
8. In the 'Worksheet' field enter 'Sheet1' and select 'First Line is Field Names'.
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9. Click 'Auto map' to map the fields.
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10. Click 'OK' to link the products.[image: image160.bmp]
































































































Product selected in the preview





Title of layout appears in title bar





HTML code for layout appears in Layout Code panel
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